Dec 16, 2012

openSUSE Forums: VLC no longer plays video with h264 encoding?

openSUSE Forums
openSUSE Forums
VLC no longer plays video with h264 encoding?
Dec 16th 2012, 21:21

opensuse v12.2
VLC media player - 2.0.4 Twoflower
Nvidia gt 470, nouveau driver

I received a MOV video file from a friend. When I tried to play it with VLC, I got this:

No suitable decoder module:
VLC does not support the audio or video format "h264". Unfortunately there is no way for you to fix this.

Using VLC with the -vv option, this anomaly showed in the listing:


[0x7f000cc06788] main decoder debug: looking for decoder module: 32 candidates
[0x7f000cc06788] main decoder warning: cannot load module `/usr/lib64/vlc/plugins/codec/' (/usr/lib64/ symbol av_image_get_buffer_size, version LIBAVUTIL_51 not defined in file with link time reference)
[0x7f000cc06788] main decoder error: corrupt module: /usr/lib64/vlc/plugins/codec/
[0x7f000cc06788] main decoder debug: no decoder module matching "any" could be loaded
[0x7f000cc06788] main decoder debug: TIMER module_need() : 11.961 ms - Total 11.961 ms / 1 intvls (Avg 11.961 ms)
[0x7f000cc06788] main decoder error: no suitable decoder module for fourcc `h264'. VLC probably does not support this sound or video format.

Has anyone else seen this problem? Have a solution?

You are receiving this email because you subscribed to this feed at

If you no longer wish to receive these emails, you can unsubscribe from this feed, or manage all your subscriptions

No comments: